Ticket #41 (closed defect: fixed)
change of name for AdaptiveExponentialIF_alpha
|Reported by:||emuller||Owned by:||emuller|
In PyNN it's called AdaptiveExponentialIF_alpha
but I think we should change the name to
Since neuron types are really: ExpIF, IF, QuadIF (Izhikevich-type), HH, etc...
and cond_alpha, curr_exp, cond_exp are synapse types
CubaSFA describes the current based adaptation mechanisms
SubthrAdap? decsripes the sub-threshold adaptation
CobaSFA then describes conductance based adaptation mechanisms
as in IF_cond_exp_sfa_rr
should be IF_cond_exp_CobaSFA_CobaSFA
since the sfa and rr mechanisms are the same actually, just different time constants. That model has no sub-threshold adaptation. (Romain reported in his paper it was not strictly necessary to get a good fit to data).
Mechanims such as CobaSFA, CobaSFA, SubthrAdap?, CubaSFA strictly speaking should not be part of the neuron model, but should be something like NeuronDynamics? which can be added to a Neuron. For NEST, at Neuron creation time, otherwise Raise error. But NEURON, and I recall CSIM, support adding such mechanisms after the fact ...
Synapses too ... cond_exp, curr_alpha ... etc.
ok this got longer than I expected ... so I better post it as a ticket...
So, may I change the name of AdaptiveExponentialIF_alpha to
and IF_cond_exp_sfa_rr to